App Slowness

Incident Report for Air

Resolved

This incident has been resolved, and we will continue monitoring for further issues.
Posted Aug 07, 2025 - 17:56 UTC

Investigating

We're currently investigating reports of degraded performance across the Air app. Users may experience slow load times, delays when searching, or timeouts when accessing certain features.
Posted Aug 07, 2025 - 14:37 UTC
This incident affected: Web App.