Indexing delays have stabilized. Uploads are now processing successfully, and asset visibility should be back to normal. We’ve upgraded our search engine to prevent future issues. While we’re still monitoring for any residual errors, no user impact is expected at this time. Thanks for your patience.
Posted May 08, 2025 - 15:51 UTC
Identified
We’ve identified a backlog in our search indexing system that’s delaying asset visibility. We’re working to resolve the root cause and will continue to share updates.
Posted May 08, 2025 - 15:46 UTC
Investigating
We’re investigating delays in asset indexing that may cause uploads to temporarily disappear from boards, especially after refreshing or navigating away. Collaborators may also not see newly uploaded content. Assets are not lost and will appear once the backlog clears. We’ll share updates as we learn more.