This incident has now been resolved. The app should be fully responsive and operating normally again.
Posted Nov 03, 2025 - 14:43 UTC
Identified
We’ve identified the underlying cause of the issue and are implementing a fix. Some users may continue to experience slow load times while we work to restore service.
Posted Nov 03, 2025 - 14:41 UTC
Investigating
We’re currently aware of an issue causing the app to be unresponsive for some users. Our engineering team is investigating and working to restore full functionality as quickly as possible.