This incident has been resolved, but we will continue to monitor. Previously impacted uploads will be processed.
Posted May 07, 2025 - 15:51 UTC
Identified
We have identified the issue and are working on a fix. You may continue to see delayed processing of your assets in uploads and imports. Any assets that have been delayed will be processed. No action is needed on your end.
Posted May 07, 2025 - 14:35 UTC
Investigating
We're currently experiencing technical issues affecting our background processing systems. You may notice delays in media processing for some content. Our engineering team is working to restore full functionality as soon as possible. We'll provide updates as soon as we have more information.